[MLton] MLTON_THREAD
Matthew Fluet
fluet@cs.cornell.edu
Fri, 20 Aug 2004 11:07:28 -0400 (EDT)
> How about changing the name of type MLton.Thread.ready_t to simply
> MLton.Thread.ready? The _t doesn't do anything for me, plus we don't
> use _ in type names.
I thought that
structure Ready : sig type t end
we a bit much, and "_t" made the connection that ready_t was related to
'a t.
But, I don't object to just ready.
> I like the prep* functions. Another possible naming choice is ready*,
> since ready is actually a verb.
I went with ready* initially, but virtually every threaded application
implements a ready queue and uses "ready" as the function to enque a
thread. And prep[are] is a verb.
Given this, I'm tempted to go back to your earlier suggestion of
type runnable, which would make ready* functions a less obvious choice,
and seems natural with prep[are a thread to be run]* functions.
Another choice: type active and activate*