<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=UTF-8" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffee" text="#000000">
Vesa Karvonen wrote:<br>
<br>
<blockquote
 cite="mid:9e43b9a0703160703q7b3fb6ejac3933e6ebc9b8b8@mail.gmail.com"
 type="cite">
  <blockquote type="cite">Okay, I'll look into preparing a proposal for
these.  I already put
    <br>
together some common signatures for sequences (SEQUENCE_CORE,
    <br>
SEQUENCE_FINITE, SEQUENCE_INFINITE).
    <br>
  </blockquote>
  <br>
Great.  I'm looking forward to seeing these.
  <br>
</blockquote>
<br>
As you saw, I sent out my proposals for »SEQUENCE_CORE«,
»SEQUENCE_FINITE«, »SEQUENCE_INFINITE«.  However, I haven't thought as
much on the signatures for sorting as I want to try and reconcile the
three general sequence signatures with the proposal by Stephen.  <br>
<br>
<blockquote
 cite="mid:9e43b9a0703160703q7b3fb6ejac3933e6ebc9b8b8@mail.gmail.com"
 type="cite">Maybe we should just use oo for now until a better idea
merges.
  <br>
</blockquote>
<br>
<br>
I've done that.  As I mentioned, I think, I was considering captial »O«
as another possibility, but figured it would be best to get feedback on
that first.<br>
<br>
<br>
<blockquote
 cite="mid:9e43b9a0703160703q7b3fb6ejac3933e6ebc9b8b8@mail.gmail.com"
 type="cite">So, based on the above description, the function could be
named, for
  <br>
example, "toBindable" or "toBind".  I'm not suggesting here that this
  <br>
would necessarily be a better name than "hoist".  Feel free to choose
the
  <br>
name.
  <br>
</blockquote>
<br>
I've settled on calling it »pure« for now.  But I'm still open to
debate on it.<br>
<br>
<br>
<blockquote
 cite="mid:9e43b9a0703160703q7b3fb6ejac3933e6ebc9b8b8@mail.gmail.com"
 type="cite">BTW, you could also write it as
  <br>
  <br>
 fun thunk th = return () &gt;&gt;= hoist th
  <br>
  <br>
or
  <br>
  <br>
 fun thunk th = return () &gt;&gt;= toBind th
  <br>
</blockquote>
<br>
    That is how it is implemented actually; I just expanded it out
because the name for »pure« was still under discussion.   <br>
<br>
<blockquote
 cite="mid:9e43b9a0703160703q7b3fb6ejac3933e6ebc9b8b8@mail.gmail.com"
 type="cite">Just checking how the different names would look like. 
Also, an
  <br>
alternative for "thunk" could be "fromThunk".  Then one might write
  <br>
  <br>
  Monad.fromThunk th
  <br>
  <br>
OTOH, the name "thunk" has the advantage of being shorter.
  <br>
</blockquote>
<br>
    »fromThunk« is more pleasing in some regard, but there is already a
precedent for calling it simply »thunk« in the »PRODUCT_TYPE«
signature.  And it is shorter.<br>
<br>
<blockquote
 cite="mid:9e43b9a0703160703q7b3fb6ejac3933e6ebc9b8b8@mail.gmail.com"
 type="cite">FYI, I've had a couple of (pre)ideas for potentially
improving the fold
  <br>
technique on my "list of things to try out" for some time.  This is one
of
  <br>
the reasons why I haven't yet added any Fold stuff to the extended
basis.
  <br>
(Currently there is some Fold stuff in the misc-util library.)  I'll
try
  <br>
to find some time to consider the ideas ASAP.
  <br>
</blockquote>
<br>
    Okay, I think maybe I'll hold off on this »ZIP« until then, because
it would be nice to abstract the »FOLD« bits out of it.<br>
<br>
<pre class="moz-signature" cols="72">-- 
[Geoff Washburn|<a class="moz-txt-link-abbreviated" href="mailto:geoffw@cis.upenn.edu">geoffw@cis.upenn.edu</a>|<a class="moz-txt-link-freetext" href="http://www.cis.upenn.edu/~geoffw/">http://www.cis.upenn.edu/~geoffw/</a>]
</pre>
</body>
</html>