Matthew Fluet mfluet@intertrust.com
Thu, 9 Aug 2001 09:17:08 -0700 (PDT)

And here's the error I get:

[mfluet@starlinux bin]$ ./make-rpms
Cleaning up
Checking out sources
Instantiating version numbers
Creating source tgz
Building rpms
error: File /usr/src/redhat/SOURCES/mlton-20010809.tgz: No such file or

So it seems that it's looking in some default place.

Anyways, I've now spent some time playing with this, and the --macros
option doesn't work.  I strace'd it, and it never even opens that file.

The next thing I tried was the --rcfile option.  You should be able to set
topdir in there, but I get "bad option 'topdir'" when I try setting it to
something.  So, I tried setting the macrofiles option and adding a new
entry.  rpm first reads /usr/lib/rpm/rpmrc and then reads the file
specified by --rcfile.  What I really want is to macro-expand the
macrofiles option set in /usr/lib/rpm/rpmrc and add a new file.  But, I
just end up stomping on the old macrosfiles option.  Suggestions?

>   --macros=<file:...>        read <file:...> instead of default macro file(s)