[MLton] MinGW port mostly works

Brent Fulgham bfulgham@debian.org
Sun, 29 Aug 2004 22:04:39 -0700

On 2004-08-28 12:10:59 -0700 Stephen Weeks <sweeks@sweeks.com> wrote:

> The MinGW port mostly works.  Here are the regressions that fail.
> * The following failures may or may not be OK
>   filesys:
> 	unhandled exception: SysErr: Function not implemented [nosys]
> 	The call to Posix.FileSys.symlink.

I tried stubbing this out.  MinGW does not support symlinks (via its 
native Windows
layer), though they can be emulated to some extend via "Short Cuts".  
I haven't figured
out how to do this exactly, yet.  I'll try to take a look tomorrow.

>   unixpath:
> 	many problems

This one causes me the most concern, as it is what prevents MinGW 
MLton from
compiling from CM files.  I took a stab at trying to make some changes 
in the Basis
to support this, but had limited success getting it to work.

> Posix.FileSys.createf.  For some reason the call to 	the open system 
> call is 
> failing.

This should work -- I suspect some flag foo is causing the problem.  
Does the
createf use the mkstemp call?

I just tried building today's CVS (as of about 6 PM western time) 
using the snapshot on
the web site as of a few days ago, and got a build failure (out of 
memory) while building.
I'll try to look into this more tomorrow.