[MLton] problems building mlton

Lukasz S Ziarek lziarek@cs.purdue.edu
Wed, 21 Jan 2004 12:17:35 -0500 (EST)

On Wed, 21 Jan 2004, Stephen Weeks wrote:

> > This is the source tarball from the webpage, the "latest public release",
> Odd.  I just downloaded that tarball from mlton.org and am building it
> with the 20030716 binary.  All seems fine.  I don't understand why you
> are getting an error.
It is odd, since I am only getting that error on one machine. I will poke
around with it a little more, any suggestions on what to check for?

As for the cvs version I get this error:

Compile SML starting
      pre codegen starting
         parseAndElaborate starting
../lib/mlton/pervasive/pervasive.sml:36.26-36.32 Error: unbound structure
         parseAndElaborate raised in 0.04 + 0.00 (0% GC)
      pre codegen raised in 0.05 + 0.00 (0% GC)
   Compile SML raised in 0.05 + 0.00 (0% GC)

gmp.h is on the machine and i have moved a copy of it to
/usr/lib/mlton/include, and this is the library that I set in the mlton
script located in mlton/bin. I also added the -lib-search /usr/lib  to the
same script. Although, I never once got an error about mlton not finding
gmp.h or -lgmp, I just thought that the error above would have something
to do with gmp.h.   Any suggestions on this?


> > I am going to try the cvs version. I didnt have any problems installing
> > the src tarball on my laptop, though this also begs the question of
> > whether or not I should use the tar src or the cvs one?
> Much better to use CVS.
> _______________________________________________
> MLton mailing list
> MLton@mlton.org
> http://www.mlton.org/mailman/listinfo/mlton