[MLton] Finished (?) MLton.Child

Stephen Weeks MLton@mlton.org
Sat, 27 Nov 2004 18:36:05 -0800

> Using 'mlton @MLton use-mmap -- test.sml' does succeed in building.
> It also now works in linux again.
> Why is system() and/or spawn() broken?
> My patch did not touch these.
> Using mlton+mmap compiles, but the resulting binary is also FUBAR'd.
> When run with '@MLton use-mmap --' I get:
> unhandled exception: SysErr: Function not implemented [nosys]
> What function is unimplemented? 
> This is cygwin+mmap! This worked with my patch.

Sorry about that.  Another reversed condition.  I had forkIsEnabled
set to true when *not* using mmap (of course it should be enabled when
using mmap).  I've checked in a fix.  This bug was definitely not in
your patch -- it came as a result of my generalization to allow
runtime control of whether mmap is useed.

> I have not tried mingw at all since it takes me about three hours to
> rebuild mlton under windows and I got quite frustrated after
> repeated problems.

Hmmm.  You shouldn't need to rebuild the compiler for the kind of work
we're doing, which is runtime and basis library modification.  If you
change the basis library, all you need to do is 'make world', which
takes seconds.  If you change the runtime, all you need to do is 'make
world', which might take a minute.

> I was trying to prepare a patch to make cygwin+VirtualAlloc+CreateProcess
> work. However, I am unable to test it because the cvs compiler is unusable 
> under cygwin. I have attached it in case your compiler still works.

Please give it a try again.  Sorry for the problem.