[MLton] cvs commit: mlb annotations quoted
Matthew Fluet
fluet@cs.cornell.edu
Wed, 3 Nov 2004 13:15:24 -0500 (EST)
> > > ann
> > > "deadCode true"
> > > "sequenceUnit true"
> > > "warnMatch true"
> > > "warnUnused true, forceUsed"
> > > in
> > >
> > > That seems easier to read and write than the backslashes.
> >
> > Who should put in the delimiters? That is, should the sequence be
> > concatenated with ","
>
> No, each annotation should be parsed and elaborated individually, in
> sequence, just as with multiple -default-ann command line arguments.
O.k. Then we have
anns ::= "string constant"
basdec ::= ... | ann <anns> in <basdec> end
and the derived form:
basdec ::= ... | ann <anns>+ in <basdec> end
ann <anns> <anns>+ in <basdec> end
==> ann <anns> in ann <anns>+ in <basdec> end end
That is a reasonable interpretation.
> > I actually prefer the single string constant.
>
> Why?
Because it has a simpler grammer. But, I was also concerned about how to
combine them; the derived form above is a good way to think about it.