[MLton] Building MLton on Cygwin

Matthew Fluet fluet@cs.cornell.edu
Mon, 25 Jul 2005 16:44:44 -0400 (EDT)

> I tried building MLton on Cygwin, but ran into problems.
> First I downloaded both the binary and source version of
> 20041109 from <http://mlton.org/Download>. The binary
> version was unpacked in /.
> To test it I saved the hello world program in hello.sml.
>     print "Hello, world!\n";
> --------
> js@js-dell ~
> $ mlton
> MLton 20041109 (built Tue Nov 09 15:33:07 2004 on cygwin)
> js@js-dell ~
> $ mlton hello.sml
> call to system failed with signal B:
> gcc -c -I/usr/lib/mlton/include -O1 -fno-strict-aliasing -fomit-frame-pointer -w -fno-strength-reduce -fschedule-insns -fschedule-insns2 -malign-functions=5 -malign-jumps=2 -malign-loops=2 -mcpu=pentiumpro -o /tmp/fileexM8D3.o /tmp/filelhrUpk.1.c
> As you can see GCC died on me. The GCC installed is 3.4.4.

I'm seeing a similar problem on my cygwin machine.  Running mlton, I get a
popup dialog saying "cc1 failed to start because cygwin1.dll could not be
found" and mlton reports "call to system failed with exit status 1".

However, if I run mlton with -verbose 1 -keep g -keep o, and I cut-n-paste 
the system call line, then gcc seems to run fine.