[MLton] x86_64 bootstrap instructions?

Neil Conway neilc at samurai.com
Fri Oct 27 12:51:14 PDT 2006


I've been trying to self-compile mlton on Linux/AMD64, but I haven't yet
managed to succeed. I'm using the on-20050822-x86_64-branch code, and
I've tried the following:

- installed 32-bit libgmp
- installed 32-bit mlton i386 binaries; verified that mlton seems to
superficially work
- I ran `linux32 make runtime` from the toplevel of the SVN tree, but it
errored out:

cd gen && ./gen-types
rm -f gen/gen-types
rm -f c-types.h ml-types.h
cp gen/c-types.h c-types.h
cp gen/ml-types.h ml-types.h
mlton -output gen/gen-basis-ffi gen/gen-basis-ffi.sml
/tmp/cciVV3uL.s: Assembler messages:
/tmp/cciVV3uL.s:17: Error: `pusha' is not supported in 64-bit mode
/tmp/cciVV3uL.s:25: Error: `popa' is not supported in 64-bit mode
call to system failed with exit status 1:
gcc -std=gnu99 -c -I/home/neilc/local/mlton/lib/mlton/include -O1
-fno-strict-aliasing -fomit-frame-pointer -w -fno-strength-reduce
-fschedule-insns -fschedule-insns2 -malign-functions=5 -malign-jumps=2
-malign-loops=2 -o /tmp/file21JPVB.o /tmp/filek20IOi.1.c
make[3]: *** [gen/basis-ffi.h] Error 1
make[3]: Leaving directory `/home/neilc/mlton_amd64/runtime'

(Running just "make runtime" yielded a different error earlier in the
compilation process:

cd gdtoa &&                                     \
                gcc -std=gnu99 -I. -Iplatform  -m32 -mtune=opteron -O2
-fomit-frame-pointer  -pedantic -Wall  -Wextra -Wformat=2
-Wno-format-nonliteral -Wuninitialized  -Winit-self  -Wstrict-aliasing=2
-Wfloat-equal  -Wundef -Wshadow  -Wpointer-arith  -Wbad-function-cast
-Wcast-qual -Wcast-align  -Wwrite-strings -Waggregate-return
-Wstrict-prototypes  -Wold-style-definition -Wmissing-prototypes
-Wmissing-declarations -Wmissing-field-initializers -Wmissing-noreturn
-Wmissing-format-attribute -Wredundant-decls  -Wnested-externs
-Wlong-long  -Wdisabled-optimization  -Winline        \
                        -w -O1 -c -DINFNAN_CHECK        \
In file included from /usr/include/features.h:346,
                 from /usr/include/stdio.h:28,
                 from arithchk.c:27:
/usr/include/gnu/stubs.h:7:27: error: gnu/stubs-32.h: No such file or

... then many more copies of the same error message.)

Any advice on how to get this working would be welcome.

Thanks in advance,


More information about the MLton mailing list