[MLton] Minor evolution request

Stephen Weeks MLton@mlton.org
Tue, 9 Dec 2003 11:54:39 -0800

I agree that hardwiring in a divisor doesn't sound so great.  How
about adding the ability to set ramSlop at runtime?

	val MLton.GC.setRamSlop: real -> unit

I don't think that would be too tough to implement.  With it, whenever
a master is going to fork some children and knows the number of
processors (presumably via some other _import), he can set the ramSlop
appropriately before starting each child.

Maybe we need a better name than ramSlop?  ramUsed? ramAvailable?