[MLton] cvs commit: mlb annotations quoted
Wed, 3 Nov 2004 08:47:47 -0500 (EST)
> Sorry I didn't think of this sooner. Why not make the grammar allow a
> sequence of quoted strings for annotations? So, one could write
> "deadCode true"
> "sequenceUnit true"
> "warnMatch true"
> "warnUnused true, forceUsed"
> That seems easier to read and write than the backslashes.
Who should put in the delimiters? That is, should the sequence be
concatenated with "," or should one write:
"warnUnused true, forceUsed"
I actually prefer the single string constant. I maintain that one spends
much less time writing .mlbs than writing .smls, and one spends even less
time writing annotations. The above is about as big as they get, and that
includes the expert deadCode annotation.