[MLton] questions on mlton

Jesper Louis Andersen jlouis@mongers.org
Thu, 11 Nov 2004 23:32:24 +0100

Quoting Heath Putnam (hp@heathputnam.com):
> It looks like I've got to upgrade from OpenBSD 3.4 in order to run the
> new MLton. OpenBSD 3.4 has a slightly different signal API (looks like
> NetBSD) than what MLton uses. I get errors in gc.c.

I am pretty sure my port was made on a 3.5-current OpenBSD. I assume
strongly that 3.6 will run MLton. Apart from that, 3.4 OpenBSD is
now non-supported with security fixes anymore, so you might as well
upgrade because of that thing alone.